Ubuntu en nvidia drivers.... aaaaaarrrrrrrgggggghhhhhhh

Iedereen kan hier terecht met vragen over allerhande open source software die niet in de andere fora past.
Jokke
Berichten: 17
Lid geworden op: 8 mei 2005, 8:20
    unknown unknown

Ubuntu en nvidia drivers.... aaaaaarrrrrrrgggggghhhhhhh

Bericht door Jokke »

Sorry... het moest er effe uit :)
Het lukt me maar niet om de nvidia drivers te installeren bij Ubuntu. Ik heb onlangs Ubuntu Edgy erop gezet, maar net als vroeger bij Ubuntu Dapper lukt het van geen kanten. Of ik het nu doe via de how to op http://albertomilone.com/latest_nvidia_udsf_edgy.html of via het script Envy... het gaat niet. Ofwel krijg ik de boodschap over X_server disabled, ofwel krijg ik een erg raar scherm waarin ik enkel blind kan werken.
Ik heb een Toshiba Satellite Pro laptop met een Geforce4 420 Go videokaart en ik weet dat daar de nodige problemen mee zijn: ik heb dus ook al alle speciale opmerkingen voor deze kaart geprobeerd, maar niets...

Ik geloof dat het gewoon niet werkt met deze videokaart... erg jammer, want zo ga ik bij één of andere woede uitbarsting de hele Ubuntuzooi er weer afgooien... (om hem nadien er dan weer op te zetten :p).

Moest er iemand zijn die toevallig nog wat tips heeft, ik hoor ze graag, want op zich pruts ik wel graag met Ubuntu :).
Gebruikersavatar
rappie pappie
Berichten: 1503
Lid geworden op: 19 januari 2006, 14:01
    unknown unknown

Bericht door rappie pappie »

Heb je deze howto's al geprobeerd. :)
Helaas heb ik geen NVIDIA.Maar ATI.

https://help.ubuntu.com/community/Binar ... nvidia%29/

Als je envy heb geinstalleerd wel eerst deinstalleren voor je aan de bovenstaande installatie methode begint.Dan moet het lukken. :wink:
Afbeelding
Jokke
Berichten: 17
Lid geworden op: 8 mei 2005, 8:20
    unknown unknown

Bericht door Jokke »

Yup rappie pappie... deze heb ik ook al geprobeerd, zonder resultaat.

Voorlopig heb ik alle nvidia drivers er maar weer afgegooid en hou ik het grafisch maar sober :).

Toch bedankt!
Gebruikersavatar
rappie pappie
Berichten: 1503
Lid geworden op: 19 januari 2006, 14:01
    unknown unknown

Bericht door rappie pappie »

Jokke schreef:
Voorlopig heb ik alle nvidia drivers er maar weer afgegooid en hou ik het grafisch maar sober :).

Toch bedankt!
:shock: Hoeveel verschillende drivers had je dan geinstalleerd?.Als je ze door elkaar gaat mixen krijg je problemen.(Géén wonder) :?

Ik vond het al zo vreemd dat een nvidia kaart niet werkt onder linux.Onder linux werkt een nvidia kaart het beste. :)
Laatst gewijzigd door rappie pappie op 10 februari 2007, 16:56, 1 keer totaal gewijzigd.
Afbeelding
Gebruikersavatar
rappie pappie
Berichten: 1503
Lid geworden op: 19 januari 2006, 14:01
    unknown unknown

Bericht door rappie pappie »

Alle oude videokaart drivers goed deinstalleren. :D

Ik heb iets gevonden over jouw videokaart in deze howto.

http://doc.gwos.org/index.php/Latest_Nvidia_Edgy

Onder troubleschooting:
7) If you own a GeForce4 420/440 Go or a GeForce4 MX 440 you should follow these steps:

sudo nano /etc/modprobe.d/options


Add this option at the end of the file:


options nvidia NVreg_SoftEDIDs=0 NVreg_Mobile=1


CTRL+O to save CTRL+X to exit

Edit your xorg.conf:


sudo nano /etc/X11/xorg.conf


Get to the "Section Screen" and add the following options


Option "ExactModeTimingsDVI" "TRUE" Option "ModeValidation" "DFP-0: NoEdidDFPMaxSizeCheck, NoVesaModes"


If you added the options that section should (approximately) look like the example below:


Section "Screen" Identifier "Screen[0]" Device "Device[0]" Monitor "Monitor[0]" DefaultDepth 24 Option "ExactModeTimingsDVI" "TRUE" Option "ModeValidation" "DFP-0: NoEdidDFPMaxSizeCheck, NoVesaModes" SubSection "Display" Depth 16 Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480" EndSubSection SubSection "Display" Depth 24 Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480" EndSubSection EndSection


If those options do not work then you may replace them with the following:


Option "ExactModeTimingsDVI" Option "UseEdidDpi" "FALSE" Option "ModeValidation" "NoEdidDFPMaxSizeCheck, NoVesaModes"


If that did not work for your card you can try setting the following option instead of the one you put before in your /etc/modprobe.d/options:


options nvidia NVreg_SoftEDIDs=0 NVreg_Mobile=4
Afbeelding
Gebruikersavatar
adri
Moderator
Berichten: 11541
Lid geworden op: 5 maart 2005, 14:00
Locatie: Diessen
    unknown unknown

Bericht door adri »

Mocht ook deze tip van rappie pappie niet het gewenste resultaat geven, probeer het dan eens op de 'ouderwetse' manier: http://www.alleslinux.com/artikels/nvid ... ut=default

Als ook dat niet werkt, dan raad ik je aan om je aan te melden op het NVidia Linux forum, daar hebben ze mij ook een keer goed vooruitgeholpen. ;)
Afbeelding
Jokke
Berichten: 17
Lid geworden op: 8 mei 2005, 8:20
    unknown unknown

Bericht door Jokke »

rappie pappie schreef:
:shock: Hoeveel verschillende drivers had je dan geinstalleerd?.Als je ze door elkaar gaat mixen krijg je problemen.(Géén wonder) :?

Ik vond het al zo vreemd dat een nvidia kaart niet werkt onder linux.Onder linux werkt een nvidia kaart het beste. :)
nee, ik heb me verkeerd uitgedrukt... ik had er altijd maar eentje geïnstalleerd hoor, en telkens gedeïnstalleerd voor de volgende poging :)
Gebruikersavatar
rappie pappie
Berichten: 1503
Lid geworden op: 19 januari 2006, 14:01
    unknown unknown

Bericht door rappie pappie »

Jokke schreef:
nee, ik heb me verkeerd uitgedrukt... ik had er altijd maar eentje geïnstalleerd hoor, en telkens gedeïnstalleerd voor de volgende poging :)
Oké maar nog niet te snel opgeven hoor!. :wink: Want het is zeker niet onmogelijk om de videokaart die jij hebt aan de praat te krijgen.Dat moet naar mijn mening goed te doen zijn. :wink:

Je hebt hier boven heel wat leesvoer gekregen,en met deze tips moet het zeker gaan lukken.Veel succes en we horen het wel. :D

Groeten rappie pappie. :wink:
Afbeelding
Jokke
Berichten: 17
Lid geworden op: 8 mei 2005, 8:20
    unknown unknown

Bericht door Jokke »

Even laten weten dat het me toch gelukt is :).

Wat heb ik gedaan?
- heb de nvidia driver (9631) gedownload en geïnstalleerd zoals beschreven op de nvidia site (kon wel niet de laatste versie installeren, want die ondersteunt mijn videokaart blijkbaar niet meer)
- toen de installatie afgelopen was (zonder foutmelding) was ik er al wat op vooruitgegaan: bij herstarten hoorde ik de normale geluidjes, kon zelfs inloggen, alleen... alles was zwart, en zo volledig blind werken is toch ook niet je dat :P
- dit probleem bleek beschreven en opgelost te zijn op http://www.nvnews.net/vbulletin/showthr ... ost1121320
- het volstond dus om één regeltje toe te voegen aan de xorg.conf en het werkt!

Ik heb nog wel wat problemen met de resolutie (kan mijn gewenste resolutie niet meer selecteren) maar dat zal wel opgelost geraken!

Bedankt voor de hulp!
Gebruikersavatar
rappie pappie
Berichten: 1503
Lid geworden op: 19 januari 2006, 14:01
    unknown unknown

Bericht door rappie pappie »

Jokke schreef:Even laten weten dat het me toch gelukt is :).
Gefeliciteerd jokke. :D :wink:
Afbeelding
Gebruikersavatar
adri
Moderator
Berichten: 11541
Lid geworden op: 5 maart 2005, 14:00
Locatie: Diessen
    unknown unknown

Bericht door adri »

Proficiat!
De methode die op de NVidia-site beschreven staat is dus dezelfde als die ik eerder plaatste ('ouderwetse' methode).
Dat werkt gewoon altijd.
Dat forum, daar heb ik dus ook eens gepost, vanwege hetzelfde euvel (schermresolutie niet in kunnen stellen), misschien dat je er wat aan hebt.

Succes.
Afbeelding
Gebruikersavatar
Z_God
Berichten: 410
Lid geworden op: 12 oktober 2003, 22:36
Locatie: Enschede
    unknown unknown

Bericht door Z_God »

adri schreef:Mocht ook deze tip van rappie pappie niet het gewenste resultaat geven, probeer het dan eens op de 'ouderwetse' manier: http://www.alleslinux.com/artikels/nvid ... ut=default
Dit zal wel iedere keer kapot gaan als je je kernel upgradet.

Daarnaast is de guide wel erg omslachtig. Je kan ook gewoon kdm afsluiten ipv naar een ander runlevel rebooten.

Ik kan de nvidia packages bij Ubuntu sterk aanraden.
Gebruikersavatar
adri
Moderator
Berichten: 11541
Lid geworden op: 5 maart 2005, 14:00
Locatie: Diessen
    unknown unknown

Bericht door adri »

Z_God schreef: Dit zal wel iedere keer kapot gaan als je je kernel upgradet.
Dat is inderdaad een nadeel. Zorg dan dat je -voordat je de kernel gaat upgraden- in /etc/X11/xorg.conf de driver van nvidia op nv zet.
Na de kernel-upgrade zal het systeem zonder de Nvidia-driver opstarten, maar met de standaard meegeleverde driver en kun je dan de Nvidia-driver opnieuw installeren.
Overigens, als het via de Ubuntu-packages goed gaat heeft dat natuurlijk de voorkeur (want veel handiger).
Afbeelding