Linux voor beginners :)

Iedereen kan hier terecht met vragen over allerhande open source software die niet in de andere fora past.
Gebruikersavatar
Koen_92
Berichten: 758
Lid geworden op: 17 oktober 2006, 19:28
Locatie: Betuwe
    unknown unknown

Bericht door Koen_92 »

Dan ga ik dat gewoon proberen :)

Ik ga straks de data van deze schijf naar die nieuwe sata schijf kopieren, dus mocht er iets fout gaan heb ik alles nog op deze schijf staan.

Zondag ga ik de pc in elkaar zetten. Ik ben benieuwd of dat gaat lukken. En daarna dus de kernel proberen te compileren.

Nog 1 vraag:
Moet ik weer kernel 2.6.27.7, of kan ik nu beter voor de 2.6.28 gaan?
Gebruikersavatar
adri
Moderator
Berichten: 11541
Lid geworden op: 5 maart 2005, 14:00
Locatie: Diessen
    unknown unknown

Bericht door adri »

Koen_92 schreef: Moet ik weer kernel 2.6.27.7, of kan ik nu beter voor de 2.6.28 gaan?
Wat jij wilt. :)
Maakt niet zo gek veel uit, denk ik.
Het is in ieder geval zeker niet zo dat 2.6.27.7 al hopeloos verouderd is (bepaald niet zelfs).
Ik denk dat ik zelf de nieuwste zou pakken.
Afbeelding
Gebruikersavatar
Koen_92
Berichten: 758
Lid geworden op: 17 oktober 2006, 19:28
Locatie: Betuwe
    unknown unknown

Bericht door Koen_92 »

Ja, dan ga ik het toch proberen met de nieuwe 2.6.28. Daarin zitten namelijk toch een aantal interessante verbeteringen.

Ik ben benieuwd of dit allemaal goed gaat aflopen......
Gelukkig kan het allemaal niet 'echt fout gaan.
Gebruikersavatar
adri
Moderator
Berichten: 11541
Lid geworden op: 5 maart 2005, 14:00
Locatie: Diessen
    unknown unknown

Bericht door adri »

Koen_92 schreef: Gelukkig kan het allemaal niet 'echt fout gaan.
Ja hoor, dat kan wel. ;)
Afbeelding
Gebruikersavatar
Koen_92
Berichten: 758
Lid geworden op: 17 oktober 2006, 19:28
Locatie: Betuwe
    unknown unknown

Bericht door Koen_92 »

Nee, dat kan niet want mijn belangrijke bestanden met de oorspronkelijke kernel staan namelijk gebackupt op een aparte schijf.

Dus als het fout gaat, is het gewoon een kwestie van een image terugzetten waarna je weer een werkend systeem hebt.

Het kan dus wel fout gaan, maar niet écht fout gaan ;)
Gebruikersavatar
Koen_92
Berichten: 758
Lid geworden op: 17 oktober 2006, 19:28
Locatie: Betuwe
    unknown unknown

Bericht door Koen_92 »

Inmiddels typ ik dit op mijn nieuwe computer. En hij is in één woord: Snel :)

Overkopiëren met dd leek goed te gaan. Het ging ook goed. Na het kopieren hoefde ik alleen maar de /home partitie te vergroten.

Alleen ging Slackware wel moeilijk doen. Bij de eerste keer opstarten kreeg ik een Kernel Panic, unable to mount root fs.
Maar dat was eenvoudig op te lossen door in fstab en lilo.conf hda door sda te vervangen. (Ik heb nu sata en die wordt met sdx ipv hdx aangesproken.)

Maar daarna werkte het nog niet. X wilde niet starten, zelf met de vesa driver niet! De nieuwe ati-driver kreeg ik ook niet aan de praat. Er is niet eens een Slackbuild 12.2 script voor de fglrxdriver!

Aangezien alles op deze computer toch supersnel gaat, heb ik er weer Ubuntu opgezet, en dit typ ik nu dus in Ubuntu.
Gebruikersavatar
adri
Moderator
Berichten: 11541
Lid geworden op: 5 maart 2005, 14:00
Locatie: Diessen
    unknown unknown

Bericht door adri »

Het was zonder enige twijfel allemaal op te lossen geweest, maar Ati is inderdaad vaak gedoe...
En Ubuntu zal zonder enige twijfel als een speer gaan op zo'n nieuw monster. :)
Afbeelding
Gebruikersavatar
Koen_92
Berichten: 758
Lid geworden op: 17 oktober 2006, 19:28
Locatie: Betuwe
    unknown unknown

Bericht door Koen_92 »

Ja, hij gaat inderdaad als een speer :)

Verder heb ik de kernel opnieuw gecompileerd, met PAE. En nu heb ik dus 4gb ram op mijn 32-bit os :)
Dat hele verhaal van PAE stond in Linuxmagazine, inclusief nederlandstalige how-to hoe je je kernel opnieuw moet compileren op Ubuntu.

1 ding vind ik vreemd: De propretäire ati-driver werkt gewoon nog, zonder aanpassingen terwijl ik op een andere kernel zit. Maar goed, het werkt en dat is het belangrijkste.

Ik wilde ook deze nog even laten zien:

Code: Selecteer alles

koen@ubuntu:~$ glxgears
51902 frames in 5.0 seconds = 10380.288 FPS
48177 frames in 5.0 seconds = 9635.288 FPS
55737 frames in 5.0 seconds = 11147.224 FPS
55713 frames in 5.0 seconds = 11142.544 FPS
^C
koen@ubuntu:~$ uname -r
2.6.27.10pae
koen@ubuntu:~$ free -m
             total       used       free     shared    buffers     cached
Mem:          4046        618       3428          0          0        299
-/+ buffers/cache:        317       3729
Swap:         4008          0       4008
koen@ubuntu:~$ 
Gebruikersavatar
adri
Moderator
Berichten: 11541
Lid geworden op: 5 maart 2005, 14:00
Locatie: Diessen
    unknown unknown

Bericht door adri »

Mooi hoor, proficiat!
Dat van die Ati-driver kan ik eerlijk gezegd ook niet helemaal plaatsen...

Hoe dan ook, je hebt nu een puike computer en misschien keer je weer eens terug naar Slack (waar je waarschijnlijk wel een hoop van opgestoken hebt). ;)
Afbeelding
Gebruikersavatar
Koen_92
Berichten: 758
Lid geworden op: 17 oktober 2006, 19:28
Locatie: Betuwe
    unknown unknown

Bericht door Koen_92 »

Ati is sowieso nog af en toe moeilijk.
Maar hier op Ubuntu werkt het eigenlijk net zo goed als nVidia.

De reden dat ik toch een Ati kaart ipv nVidia gekocht heb is dit:
http://tweakers.net/nieuws/57560/amd-br ... s-uit.html
Dat terwijl nVidia alles nog geheim houdt.

Verder hebben Ati-kaarten een betere prijs/prestatieverhouding.

En ja ik kom zeker nog wel eens kijken bij Slackware :)
En je hebt gelijk dat ik van Slackware meer geleerd heb dan van Ubuntu. Dat gevoel heb ik nu af en toe wel op Ubuntu: Dat een aantal dingen vanzelf gaan met grafische tooltjes. Een beetje Windows gevoel denk ik. Het is wel handig en snel, maar je komt niet te weten wat er precies gebeurt.
Gebruikersavatar
karien
Berichten: 44
Lid geworden op: 5 november 2008, 12:58
    unknown unknown

Bericht door karien »

Ik heb een ATI 2400 en kreeg die ook niet goed ingesteld in Slackware 12.2.
Wat ik heb gedaan is (na een image maken) de xorg.conf van Zenwalk gekopieerd, waar de ATI kaart "vanzelf" goed op geiinstalleerd werd, en dit in de xorg.conf van Slackware gezet.
Tot mijn grote verbazing ging het nog goed ook en draait Slackware prima.
Wel een beetje onorthodox denk ik maar het werkt wel, voor miij tenminste.
Kan ik weer verder puzzelen met Slackware.
Gebruikersavatar
adri
Moderator
Berichten: 11541
Lid geworden op: 5 maart 2005, 14:00
Locatie: Diessen
    unknown unknown

Bericht door adri »

Het is inderdaad een beproefde methode om /etc/X11/xorg.conf gewoon over te nemen van een andere distro (kan bijv. ook een live CD zijn!). ;)
Afbeelding
Gebruikersavatar
Koen_92
Berichten: 758
Lid geworden op: 17 oktober 2006, 19:28
Locatie: Betuwe
    unknown unknown

Bericht door Koen_92 »

Ja, het enige is dat je dan nog steeds geen 3D acceleratie hebt, want op een live cd zitten geen propretaire drivers.

Maar het is bij mij nog iets erger, want ook de framebuffer werkt niet.
Als je Slackware opstart, zie je bovenaan altijd twee pinguins staan. Die worden bij mij in zwart-wit weergegeven, iets dat ook niet goed is.
Gebruikersavatar
adri
Moderator
Berichten: 11541
Lid geworden op: 5 maart 2005, 14:00
Locatie: Diessen
    unknown unknown

Bericht door adri »

Koen_92 schreef:Ja, het enige is dat je dan nog steeds geen 3D acceleratie hebt, want op een live cd zitten geen propretaire drivers.
Dat klopt, maar ook zonder 3D drivers kan xorg je wel eens wat hoofdbrekens bezorgen. Het is natuurlijk van het grootste belang dat je eerst de open source drivers aan de gang hebt, dan kun je van daaruit verder werken.
Koen_92 schreef: Maar het is bij mij nog iets erger, want ook de framebuffer werkt niet.
Als je Slackware opstart, zie je bovenaan altijd twee pinguins staan. Die worden bij mij in zwart-wit weergegeven, iets dat ook niet goed is.
Dat heb ik ook ooit eens gehad en het is op te lossen, maar ik weet zo uit het hoofd niet meer precies hoe... :)
Afbeelding
Gebruikersavatar
Koen_92
Berichten: 758
Lid geworden op: 17 oktober 2006, 19:28
Locatie: Betuwe
    unknown unknown

Bericht door Koen_92 »

adri schreef: Dat klopt, maar ook zonder 3D drivers kan xorg je wel eens wat hoofdbrekens bezorgen. Het is natuurlijk van het grootste belang dat je eerst de open source drivers aan de gang hebt, dan kun je van daaruit verder werken.
En dan hoef je eigenlijk nog niet eens aan die open source drivers te beginnen. Want zelfs de vesa driver deed het hier niet meer.
Koen_92 schreef: Maar het is bij mij nog iets erger, want ook de framebuffer werkt niet.
Als je Slackware opstart, zie je bovenaan altijd twee pinguins staan. Die worden bij mij in zwart-wit weergegeven, iets dat ook niet goed is.
Dat heb ik ook ooit eens gehad en het is op te lossen, maar ik weet zo uit het hoofd niet meer precies hoe... :)[/quote]
Volgens mij is het wel weer goed als ik Slackware opnieuw ga installeren. Maar nu zit ik best wel tevreden hier met Ubuntu.
Ik zou Slackware er naast kunnen zetten. Dualbooten even leuk, maar na een tijd wordt het een chaos, en weet je niet meer waar wat staat. Dus daar begin ik liever niet aan.
Slackware staat trouwens nog wel op mijn oude harde schijf, die hier in de kast ligt. Dus als je toevallig precies de oplossing zou weten, zou ik er even na kunnen kijken.