Voor mensen die aan Slackware Linux willen beginnen.

Iedereen kan hier terecht met vragen over allerhande open source software die niet in de andere fora past.
Gebruikersavatar
adri
Moderator
Berichten: 11541
Lid geworden op: 5 maart 2005, 14:00
Locatie: Diessen
    unknown unknown

Bericht door adri »

rener schreef:
adri schreef: Hij is wel vaak te vinden op het Slackware forum van LinuxQuestions.org, waar hij ook gewone stervelingen vooruit helpt. Vin'k toch sympathiek!
Dat zie je trouwens bij meerdere vertegenwoordigers van het eerste echelon Slackware maintainers - het lijkt een beetje in de cultuur te zitten. Zo'n positieve basishouding van de "top" ten opzichte van de gebruikers is niet altijd gegarandeerd bij veel andere projecten.
Inderdaad, ook Robby Workman is regelmatig te vinden op LQ.org en -wat minder regelmatig- zelfs Patrick Volkerding himself. :)
Afbeelding
Gebruikersavatar
adri
Moderator
Berichten: 11541
Lid geworden op: 5 maart 2005, 14:00
Locatie: Diessen
    unknown unknown

Bericht door adri »

Een -relatief- nieuwe telg aan de Linux boom is Absolute Linux.
Absolute is gebaseerd op Slackware, maar ietsje gebruikersvriendelijker (?) en toegespitst op desktop gebruik.
Standaard wordt IceWM gebruikt en is derhalve snel en zeer geschikt voor oudere machines.
Ik had er nog nooit van gehoord, maar las er gisteren een stukje over (bij toeval).
Iemand ervaring mee?
Afbeelding
Gebruikersavatar
Koen_92
Berichten: 758
Lid geworden op: 17 oktober 2006, 19:28
Locatie: Betuwe
    unknown unknown

Bericht door Koen_92 »

Het is gewoon één van de 100 afgeleiden van Slackware denk ik.
Wel uniek is dat multimedia codecs met een paar muisklikken geinstalleerd kunnen worden. (Zelf in Ubuntu is dat moeilijker)

Het tweede unieke is dat er standaard IceWM gebruikt wordt, en daarmee is deze echt uniek, want ik ken geen andere distro's met standaard IceWM.

Misschien moet ik dit maar eens in Virtualbox testen. (Maar volgens mij kun je op een oude pc toch nog het beste Slackware draaien)
rener
Berichten: 89
Lid geworden op: 31 januari 2008, 20:12
    unknown unknown

Bericht door rener »

adri schreef:Een -relatief- nieuwe telg aan de Linux boom is Absolute Linux.
Absolute is gebaseerd op Slackware, maar ietsje gebruikersvriendelijker (?) en toegespitst op desktop gebruik.
Standaard wordt IceWM gebruikt en is derhalve snel en zeer geschikt voor oudere machines.
Zo te zien wordt er in deze release gebruik gemaakt van de huge-smp kernel uit Slackware. Dat is een beetje een aparte keuze, aangezien die eigenlijk is bedoeld voor noodgevallen, volgens het "changes and hints" document uit Slackware:
it is recommended that you use one of the generic kernels
rather than the huge kernels; the huge kernels are primarily intended as
"installer" and "emergency" kernels in case you forget to make an initrd.
Op VMware is er een duidelijk verschil als Slackware met de "generic-smp" of "huge-smp" kernel wordt gedraaid: met "huge-smp" werkt alles veel trager, in zo'n mate dat het niet fijn is om er continu mee te werken. Dan is het meteen duidelijk waarom er ook nog een "generic-smp" kernel wordt meegeleverd :-).

Misschien is dat effect minder merkbaar als je "native" draait, maar desondanks betwijfel ik of deze kernel, met een grootte, voor versie 2.6.28.8, van 4,7 MB (huge-smp) tegenover 2,4 MB (generic-smp) wel geschikt is voor toepassing op oudere systemen.
Gebruikersavatar
adri
Moderator
Berichten: 11541
Lid geworden op: 5 maart 2005, 14:00
Locatie: Diessen
    unknown unknown

Bericht door adri »

Ik heb inmiddels mijn SW 12.2 installatie danig naar z'n mallemoer geholpen. :)
Inmiddels opnieuw geïnstalleerd...
Ik was eergisteren in een experimentele bui en dacht eens wat pakketjes te lozen.
Dat ging vrij goed, totdat ik de volgende dag opstartte...

Bottomline: ik had o.a. e2fsprogs verwijderd en dat moet je dus niet doen (weet ik nu). Mijn gedachte was dat als je -zoals ik- geen gebruik maakt van ext*, dat je dan e2fsprogs ook wel kunt missen. Dat was dus een akelige misrekening.
Voor de liefhebbers: mijn geklungel is hier te lezen.
Afbeelding
Gebruikersavatar
Koen_92
Berichten: 758
Lid geworden op: 17 oktober 2006, 19:28
Locatie: Betuwe
    unknown unknown

Bericht door Koen_92 »

Ja, dat ziet er niet helemaal goed uit :)
Vreemd dat je e2fsprogs nodig hebt...

Verder heb ik wel één vraag:
Waarom maak je geen backups?

Dat is echt een goede gewoonte om één keer per week te doen, je ziet maar weer wanneer het van pas kan komen. (En helemaal in een experimentele bui...)

Maar gelukkig is het allemaal weer goed gekomen :)

P.S. Ik heb ook even op Ubuntu gekeken wat er gebeurt als je dat pakket probeert te verwijderen:

Code: Selecteer alles

Het verwijderen van dit pakket kan het systeem in een onbruikbare staat achterlaten.
Weet u zeker dat u hiermee door wilt gaan? 
Heb jij op Slackware niet zo'n waarschuwing gehad? Tijdens de installatie van SW staat er volgens mij wel met koeienletters het woord REQUIRED achter het pakket.
rener
Berichten: 89
Lid geworden op: 31 januari 2008, 20:12
    unknown unknown

Bericht door rener »

adri schreef: Bottomline: ik had o.a. e2fsprogs verwijderd en dat moet je dus niet doen (weet ik nu). Mijn gedachte was dat als je -zoals ik- geen gebruik maakt van ext*, dat je dan e2fsprogs ook wel kunt missen.
Het programma "fsck.jsf" dat je wilde gebruiken verwijst vermoedelijk via een symlink of shell script naar een "echte" executable. Die executable heeft afhankelijkheden naar twee library's die nu nog deel uitmaken van het pakket "e2fsprogs", namelijk "libblkid" en "libuuid". Welke executable wordt gebruikt door "fsck.jsf" weet ik niet, maar voor (bijvoorbeeld) /sbin/fsck zijn dit de afhankelijkheden:

Code: Selecteer alles

# ldd /sbin/fsck
	...
	libblkid.so.1 => /lib/libblkid.so.1
	...
	libuuid.so.1 => /lib/libuuid.so.1
	...
En waar komen die twee library's vandaan? Je raadt het al ...

Code: Selecteer alles

# egrep "libblkid|libuuid" /var/log/packages/*
...
/var/log/packages/e2fsprogs-1.41.4-i486-1:lib/libblkid.so.1.0
/var/log/packages/e2fsprogs-1.41.4-i486-1:lib/libuuid.so.1.2
In de thread wordt gesproken over het eventueel verplaatsen van deze library's naar een ander pakket met de naam "util-linux-ng", maar tot het zover is kunnen we dus blijkbaar nog even niet zonder "e2fsprogs".

Mocht het onverhoopt opnieuw gebeuren, dan is het misschien alsnog te repareren met behulp van een boot medium dat wél standaard het JFS filesysteem ondersteunt. JFS staat in ieder geval bij gparted in de lijst als "detecteerbaar". gparted is overigens zowel in CD als in USB formaat te downloaden.
Gebruikersavatar
adri
Moderator
Berichten: 11541
Lid geworden op: 5 maart 2005, 14:00
Locatie: Diessen
    unknown unknown

Bericht door adri »

Koen_92 schreef: Verder heb ik wel één vraag:
Waarom maak je geen backups?
Dat doe ik wel, maar alleen van dingen die onvervangbaar zijn & belangrijk genoeg. ;)
Daar hoort een systeem installatie in mijn ogen niet bij. Als het fout gaat dan is dat vervelend, maar niet onoverkomelijk.
Bovendien is mijn ervaring dat fuck-ups op Linux vrijwel altijd te herstellen zijn.
Koen_92 schreef:

Code: Selecteer alles

Het verwijderen van dit pakket kan het systeem in een onbruikbare staat achterlaten.
Weet u zeker dat u hiermee door wilt gaan? 
Heb jij op Slackware niet zo'n waarschuwing gehad? Tijdens de installatie van SW staat er volgens mij wel met koeienletters het woord REQUIRED achter het pakket.
Nee, op SW krijg je zo'n waarschuwing niet, daar mag en kan alles, ook je systeem om zeep helpen. :)
Het is zonder meer mijn eigen schuld, want als ik vooraf gekeken had uit welke categorie e2fsprogs komt, dan had ik beter moeten weten. Het komt uit /a...
Maar ja, het was al laat, moe, een paar borrels op en dan kijk je (ik tenminste) niet meer zo nauw. ;)
Afbeelding
Gebruikersavatar
adri
Moderator
Berichten: 11541
Lid geworden op: 5 maart 2005, 14:00
Locatie: Diessen
    unknown unknown

Bericht door adri »

rener schreef:
adri schreef: Bottomline: ik had o.a. e2fsprogs verwijderd en dat moet je dus niet doen (weet ik nu). Mijn gedachte was dat als je -zoals ik- geen gebruik maakt van ext*, dat je dan e2fsprogs ook wel kunt missen.
Het programma "fsck.jsf" dat je wilde gebruiken verwijst vermoedelijk via een symlink of shell script naar een "echte" executable. Die executable heeft afhankelijkheden naar twee library's die nu nog deel uitmaken van het pakket "e2fsprogs", namelijk "libblkid" en "libuuid". Welke executable wordt gebruikt door "fsck.jsf" weet ik niet, maar voor (bijvoorbeeld) /sbin/fsck zijn dit de afhankelijkheden:

Code: Selecteer alles

# ldd /sbin/fsck
	...
	libblkid.so.1 => /lib/libblkid.so.1
	...
	libuuid.so.1 => /lib/libuuid.so.1
	...
En waar komen die twee library's vandaan? Je raadt het al ...

Code: Selecteer alles

# egrep "libblkid|libuuid" /var/log/packages/*
...
/var/log/packages/e2fsprogs-1.41.4-i486-1:lib/libblkid.so.1.0
/var/log/packages/e2fsprogs-1.41.4-i486-1:lib/libuuid.so.1.2
In de thread wordt gesproken over het eventueel verplaatsen van deze library's naar een ander pakket met de naam "util-linux-ng", maar tot het zover is kunnen we dus blijkbaar nog even niet zonder "e2fsprogs".

Mocht het onverhoopt opnieuw gebeuren, dan is het misschien alsnog te repareren met behulp van een boot medium dat wél standaard het JFS filesysteem ondersteunt. JFS staat in ieder geval bij gparted in de lijst als "detecteerbaar". gparted is overigens zowel in CD als in USB formaat te downloaden.
Dat is interessante info rener!
Ik had gehoopt dat Robby Workman mijn laatste vraag in die topic nog zou beantwoorden (hij weet dit zonder twijfel ook), maar helaas.
Overigens heb ik enkele keren fsck.jfs gedraaid en dat leverde geen enkele foutmelding op! Het kan dus goed zijn dat die fsck niet goed werkte...
De laatste puzzelstukjes vallen nu wel op zijn plaats. :)
Overigens heb ik een Gparted live CD, maar ik heb er niet eens aan gedacht om die te gebruiken, ik had immers Slax en Knoppix al tevergeefs opgestart.
Achteraf (kun je een koe in zijn kont kijken), denk ik dat misschien toch e.e.a. te redden was geweest als ik via een live CD in fstab het bestandssyteem zelf ingevuld had. Het is nl. zo dat ik na de nieuwe installatie de oude /home/ niet kon bereiken. Ik heb dat opgelost door in fstab het bestandssysteem aan te geven, toen was het in orde.
Achteraf...
En misschien was het daarmee ook niet gelukt, nur Spekulation. ;)
Afbeelding
Manuel
Berichten: 2539
Lid geworden op: 21 december 2004, 20:16
Locatie: Alkmaar, Nederland
    unknown unknown

Bericht door Manuel »

adri schreef:
Manuel schreef: P.S. Ik heb je zoekplugin voor Slacky.eu (12.2) een 'Fully Working' review gegeven, want het werkt zoals het hoort :wink:
Dank U! :)
Welverdiend! :)
adri schreef:
Manuel schreef:@ Rener: bedankt voor de info over mogelijk snel nieuwe Slackware. Misschien wacht ik dan nog even met de definitieve installatie van m'n nieuwe gebruikte pc. Nu dan alleen nog een test partitie met 12.2 daarop.
Nou...
Dat schijnt toch nog wel een 4 tot 6 maanden te duren, voordat de volgende stabiele release van Slackware uitkomt.
SW 12.2 is nog maar drie maanden uit.
Zo lang nog? Daar ga ik niet op wachten... Ondertussen staat Slack 12.2 er op, draait lekker, extra geheugen komt over een paar dagen.
Manuel
Berichten: 2539
Lid geworden op: 21 december 2004, 20:16
Locatie: Alkmaar, Nederland
    unknown unknown

Bericht door Manuel »

rener schreef:Inderdaad, het kan nog even duren voordat uiteindelijk ook het pakket "aaa_base" (met de nieuwe /etc/slackware-version) wordt bijgewerkt. Je moet het dan ook meer zien als een avontuur: kijk (nog) niet naar het eindpunt, maar geniet van de reis ernaar toe :-D.

... of, mocht het genieten toch wat tegenvallen: verleg je grenzen ;-).
De resis, niet het reisdoel, juist :)
Gebruikersavatar
adri
Moderator
Berichten: 11541
Lid geworden op: 5 maart 2005, 14:00
Locatie: Diessen
    unknown unknown

Bericht door adri »

Omdat ik nu eenmaal toch mijn pc opnieuw geïnstalleerd had (niet geheel vrijwillig...) besloot ik mijn andere -oudere- pc ook maar eens te upgraden naar SW 12.2. Ik had zin om eens een tamelijk minimale installatie te doen in de hoop dat e.e.a daarmee sneller zou worden. M.n. Xfce vond ik altijd nou niet bepaald sneller dan KDE, dus mijn redenering was dat als ik KDE er nou eens af zou laten, dat wellicht zou schelen.
Dat was een behoorlijke tegenvaller. Het maakt gewoon helemaal niks uit t.o.v. een full install. Ik heb het niet geklokt, maar je merkt het wel als iets vlotter draait of niet. En dat is dus niet het geval.
Bij deze dus mijn advies: ga voor een full install, het maakt werkelijk geen donder uit. De enige reden om een minimale installatie te doen is gebrek aan schijfruimte.
Maar dat is bij mij niet aan de orde. :)
Afbeelding
Gebruikersavatar
adri
Moderator
Berichten: 11541
Lid geworden op: 5 maart 2005, 14:00
Locatie: Diessen
    Linux Firefox

Re: Voor mensen die aan Slackware Linux willen beginnen.

Bericht door adri »

Voor de liefhebbers is er nu portable Slackware.
Een lid van LinuxQuestions.org heeft dus een portable Slackware (12.2) gemaakt die op een USB-stick past. Die stick moet dan wel 8GB zijn, maar dan heb je ook een volledige Slackware installatie op iedere gewenste Windows of Linux pc draaien (inc. KDE).
Het is allemaal nog erg Alpha en de scherpe randjes moeten er nog af, maar momenteel is hij alweer bezig met een portable Slackware die op een USB-stick van 4 GB past. Daar staat dan geen KDE op, maar Fluxbox.
Wie het geknutsel wil volgen kan terecht op LinuxQuestion.org.
Afbeelding
Gebruikersavatar
Koen_92
Berichten: 758
Lid geworden op: 17 oktober 2006, 19:28
Locatie: Betuwe
    Windows XP Firefox

Re: Voor mensen die aan Slackware Linux willen beginnen.

Bericht door Koen_92 »

Dat ziet er wel leuk uit.
Echter wordt er gebruik gemaakt van Qemu, dat is net als Virtualbox een virtualiser.
Het verschil is echter dat je Qemu portable kunt gebruiken, en Virtualbox niet.

Dit is dus gewoon een virtuele Slackware (en dit kan dus ook met ieder ander os)

Voor Windows is er wel een hele mooie portable versie van Ubuntu:
http://portableubuntu.demonccc.cloudius.com.ar/

Deze gaat verder dan Qemu, als je daar namelijke en programma in Ubuntu opent, verschijnt deze in de Windows taakbalk!
Klik op 'media' voor screenshots.
Gebruikersavatar
adri
Moderator
Berichten: 11541
Lid geworden op: 5 maart 2005, 14:00
Locatie: Diessen
    Linux Firefox

Re: Voor mensen die aan Slackware Linux willen beginnen.

Bericht door adri »

Dat ziet er aardig uit ja.
Het draait inderdaad (dat vergat ik te melden) op Qemu (een virtuele machine).
Inmiddels is de bedenker van portable Slackware al weer verder en heeft het -zoals al aangekondigd- nu draaien vanaf een 4 GB USB-stick.
Ook die avonturen zijn live te volgen en wel hier. :)
Afbeelding