probleem met html code

Nvu, Kompozer en Bluegriffon zijn open source (WYSIWYG) programma's waarmee je een website kunt maken en onderhouden (vergelijkbaar met FrontPage / Dreamweaver).
rich-an
Berichten: 16
Lid geworden op: 24 september 2011, 13:25
    Windows Vista Internet Explorer 8

probleem met html code

Bericht door rich-an »

het volgende gaat fout in kompozer.

ik heb een code gekregen van de leverancier van ons computer systeem in de winkel om je aan te melden voor de nieuwsbrief.
<iframe scrolling="no" allowtransparency="true" src="http://www.winkeladmin.nl/nieuwsbrief/e ... JULLIECODE"
frameborder="0" width="100%" height="250"> <p>Your browser does not support iframes.</p> </iframe>

dan sla ik de pagina op, en doe ik hem uploaden.
Dan geeft hij tijdens het uploaden al een foutcode

550 permission denied
en als ik dan op ok klik
zegt hij
The file/C:/users/rich-an/Documents/Pinokkio/website pinokkio aangepast/ emailadres-extern-aanmelden.asp.html cannot be found. Please check the location and try again.
ALs ik dan naar de code kijk in kompozer dan heeft hij inderdaad de code veranderd naar

<iframe allowtransparency="false"
src="emailadres-extern-aanmelden.asp.htm" frameborder="0"
height="150" scrolling="no" width="75%">
&lt;p&gt;Your browser does not support
iframes.&lt;/p&gt; </iframe><br>


Hoe kan dit ?
En wat doe ik fout?

BVD
Richard
Gebruikersavatar
nirwana
Beheerder
Berichten: 11423
Lid geworden op: 19 september 2003, 5:09
    Windows 7 Firefox

Re: probleem met html code

Bericht door nirwana »

Richard,

Hoe heb je deze code in de pagina toegevoegd ?

Ik heb dit net ook gedaan in een test-pagina via het menu Invoegen > HTML...
Dat ziet er verbazingwekkend goed uit, want na toevoegen van de code wordt zelfs de inhoud van het iFrame in de pagina in Kompozer getoond. Dat betekent dus dat Kompozer dit wel herkend.

Ik dacht altijd dat Kompozer niets met frames en iframes kon aanvangen, maar blijkbaar is er op dat vlak wel iets veranderd.

Kortom, probeer de code eens op die manier in de pagina in te voegen.
Met vriendelijke groet,

Martijn
[ Mede-oprichter + webmaster MozBrowser | beheerder Startpagina's over freeware, GIMP, Mozilla en OpenOffice.org / LibreOffice, Ubuntu
rich-an
Berichten: 16
Lid geworden op: 24 september 2011, 13:25
    Windows Vista Internet Explorer 8

Re: probleem met html code

Bericht door rich-an »

HOi Martijn,

Heb dit inderdaad toegevoegd via
insert - html

Dan ziet het er goed uit, maar na opslaan en publiseren veranderd de code zoals beschreven.
Gebruikersavatar
nirwana
Beheerder
Berichten: 11423
Lid geworden op: 19 september 2003, 5:09
    Windows 7 Firefox

Re: probleem met html code

Bericht door nirwana »

Richard,

Na het lokaal Opslaan ziet de pagina er nog goed uit. Dan zou dit veranderen haast door het Publiceren moeten komen.

Het publiceren heb ik net wel uitgeprobeerd, maar dat krijg ik niet direct voor elkaar. Ik publiceer doorgaans geen website met Kompozer. Daar gebruik ik een losstaand FTP-programma voor (Filezilla), omdat zo'n programma daar beter in is.
Met vriendelijke groet,

Martijn
[ Mede-oprichter + webmaster MozBrowser | beheerder Startpagina's over freeware, GIMP, Mozilla en OpenOffice.org / LibreOffice, Ubuntu
rich-an
Berichten: 16
Lid geworden op: 24 september 2011, 13:25
    Macintosh Safari

Re: probleem met html code

Bericht door rich-an »

Dan zal ik denk toch ook maar daar op over moeten stappen.
Heb alleen geen idee hoe dit werkt.

Maargoed, daar is vast wel uit te komen.
Gebruikersavatar
Frederik
Moderator
Berichten: 4262
Lid geworden op: 1 juli 2004, 16:16
Locatie: Vriescheloo
    Windows 7 Firefox

Re: probleem met html code

Bericht door Frederik »

Alstublieft: kleine verhandeling over Filezilla
rich-an
Berichten: 16
Lid geworden op: 24 september 2011, 13:25
    Macintosh Safari

Re: probleem met html code

Bericht door rich-an »

Thanks, zal er van het weekend me er eens in gaan verdiepen.