Firefox NL wordt vanaf nu automatisch gebouwd

Hier kun je je opmerkingen over de Nederlandse Firefox-vertaling kwijt.
Barend
Berichten: 34
Lid geworden op: 22 oktober 2004, 14:07
    unknown unknown

Bericht door Barend »

Yep, de vertaling ister. Proficiat! Moet wel wennen aan gereedschappen ipv opties en bladerprogramma... 8)
Eerste recensie:
Hij start OKee.
Nog niet klaar voor massa gebruik:

Hulp - over geeft geweldige fout
Onder in beeld ipv status bar:
<key id=key-openHelp
------^

Barend
Gebruikersavatar
Mad Maks
Berichten: 1300
Lid geworden op: 7 oktober 2003, 16:58
Locatie: Haarlem
    unknown unknown

Bericht door Mad Maks »

Ik denk dat het woord opties snel terugkomt ;-)

over die fout melding: het is een bekende bug (weet het nummer zo snel niet). Als de help files nog niet aawezig zijn geeft FF een Parse fout. daar wordt aangewerkt (in de trant van als er nog geen vertaling is moet de engelse versie gebruikt worden)

Groet

MM
Gebruikersavatar
nirwana
Beheerder
Berichten: 11432
Lid geworden op: 19 september 2003, 5:09
    unknown unknown

Bericht door nirwana »

Mad Maks schreef:over die fout melding: het is een bekende bug (weet het nummer zo snel niet). Als de help files nog niet aawezig zijn geeft FF een Parse fout. daar wordt aangewerkt (in de trant van als er nog geen vertaling is moet de engelse versie gebruikt worden)
Ik wilde er net aan gaan werken om te zien of ik die melding weg kon krijgen. Eerst maar eens naar de HelpViewer-site gesurft (gebladerd in dit geval) en op Installatie geklikt. Maar daar wordt alleen nog de Thunderbird-versie aangeboden, omdat de Firefox-versie standaard is toegevoegd aan het programma.

Dan maar eens in de profiel-bestanden kijken of daaruit iets te verwijderen zou zijn. Daarvoor heb ik ChromEdit geinstalleerd (via http://extensionroom.mozdev.org/more-info.php/chromedit ). Vervolgens de browser herstart.

Maar na deze herstart viel het mij op dat de betreffende melding opeens verdwenen was. Kortom, probleem voorlopig opgelost. Ik denk dus dat je dit al oplost door een willekeurige extensie te installeren in Firefox. Dan zal er iets zijn dat de chrome-bestanden doorfietst en daarom de Firefox Help-onderdeel eruit verwijdert ?

En voor de toekomst zal Firefox Help waarschijnlijk gewoon bijgevoegd worden. In eerste instantie nog in het Engels en daarna kunnen we als volgende project aan die vertaling gaan werken. Hier staat nog de bug-beschrijving vanuit de tijd dat het nog FirebirdHelp heette: http://bugzilla.mozdev.org/show_bug.cgi?id=5655
Met vriendelijke groet,

Martijn
[ Mede-oprichter + webmaster MozBrowser | beheerder Startpagina's over freeware, GIMP, Mozilla en OpenOffice.org / LibreOffice, Ubuntu
Gebruikersavatar
Gert-Paul
Berichten: 2358
Lid geworden op: 4 maart 2004, 17:48
    unknown unknown

Bericht door Gert-Paul »

nirwana schreef:En voor de toekomst zal Firefox Help waarschijnlijk gewoon bijgevoegd worden. In eerste instantie nog in het Engels en daarna kunnen we als volgende project aan die vertaling gaan werken. Hier staat nog de bug-beschrijving vanuit de tijd dat het nog FirebirdHelp heette: http://bugzilla.mozdev.org/show_bug.cgi?id=5655
Ik heb de afgelopen week al wat vertaald aan de help, bebaseerd op wat eerder door jou en Erik gedaan is. Zo heb ik het document voor de opties helemaal geupdate. Als het meezit, eventueel met wat hulp hier, dan moet het wel lukken dit voor 1.0 af te hebben denk ik.

Ik had trouwens met een nieuw profiel en de zip build geen problemen met de help. Dit godl ook voor mijn bestaande Engelse profiel met het nederlandse taalpakket geïnstalleerd.
Gebruikersavatar
nirwana
Beheerder
Berichten: 11432
Lid geworden op: 19 september 2003, 5:09
    unknown unknown

Bericht door nirwana »

nirwana schreef:Maar na deze herstart viel het mij op dat de betreffende melding opeens verdwenen was. Kortom, probleem voorlopig opgelost. Ik denk dus dat je dit al oplost door een willekeurige extensie te installeren in Firefox. Dan zal er iets zijn dat de chrome-bestanden doorfietst en daarom de Firefox Help-onderdeel eruit verwijdert ?
Nu staat er in mijn Hulp-menu ook een Help Contents. En die opent netjes de Firefox Help-bestanden.

Ik weet niet of dit altijd zo werkt bij een nieuwe Nederlandse Firefox-installatie of dat het komt doordat ik hier op de PC Mozilla-software in allerlei versies en smaken heb staan.
Met vriendelijke groet,

Martijn
[ Mede-oprichter + webmaster MozBrowser | beheerder Startpagina's over freeware, GIMP, Mozilla en OpenOffice.org / LibreOffice, Ubuntu
Gebruikersavatar
FFuser
Berichten: 328
Lid geworden op: 11 augustus 2004, 19:25
Locatie: Antwerpen belgium
    unknown unknown

Bericht door FFuser »

Ik wou de NL langpack installeren op linux FFX versie (0.10.1)
Dit lukte niet, ik had versie 1.0 nodig, heb ik de laatste Nighty nodig om deze te installeren?
Mozilla/5.0 (X11; U; Linux i686; nl; rv:1.8) Gecko/20051111 Firefox/1.5
Gebruikersavatar
Gert-Paul
Berichten: 2358
Lid geworden op: 4 maart 2004, 17:48
    unknown unknown

Bericht door Gert-Paul »

FFuser schreef:Ik wou de NL langpack installeren op linux FFX versie (0.10.1)
Dit lukte niet, ik had versie 1.0 nodig, heb ik de laatste Nighty nodig om deze te installeren?
Misschien dat het ook wel in 1.0PR kan, maar dat weet ik gewoon niet. Hij is opzich gemaakt voor de laatste nightlies, dus is het aan te raden hem daarop te proberen.
Op eigen risicio kun je natuurlijk wel zelf proberen. Om dat te doen moet je het bestand in een zippakket laden (bijvoorbeeld 7zip) en in het bestand install.rdf de minimumversie van 1.0 naar 0.10 veranderen.

Als je hem eerst uitgepakt had moet je hem nu natuurlijk weer inpakken. eerst als zip, waarna je zip in jar kunt veranderen.
Gebruikersavatar
FFuser
Berichten: 328
Lid geworden op: 11 augustus 2004, 19:25
Locatie: Antwerpen belgium
    unknown unknown

Bericht door FFuser »

Gert-Paul schreef:
FFuser schreef:Ik wou de NL langpack installeren op linux FFX versie (0.10.1)
Dit lukte niet, ik had versie 1.0 nodig, heb ik de laatste Nighty nodig om deze te installeren?
Misschien dat het ook wel in 1.0PR kan, maar dat weet ik gewoon niet. Hij is opzich gemaakt voor de laatste nightlies, dus is het aan te raden hem daarop te proberen.
Op eigen risicio kun je natuurlijk wel zelf proberen. Om dat te doen moet je het bestand in een zippakket laden (bijvoorbeeld 7zip) en in het bestand install.rdf de minimumversie van 1.0 naar 0.10 veranderen.

Als je hem eerst uitgepakt had moet je hem nu natuurlijk weer inpakken. eerst als zip, waarna je zip in jar kunt veranderen.
Bedankt, Ik zal wel gewoon de Linux-Installer gebruiken

[edit] Dit verliep niet zonder problemen

Ik heb geprobeert om de nl-NL Firefox RC te installeren.
Ik gebruik Linux en Heb de installer gebruikt

Ik heb de installer geunpacked en het programma ./firefox-installer gedraait

Over de isntaller zelf heb ik de volgende commentaren:
1) Alle kopjes die op dezelfde plek staan als "Voorwaarden voor het gebruik van de ..." ZIjn niet te lezen, de tekst is in de helft gedeeld
2) Bij de keuze voor welke delen geinstalleerd moeten worden krijg ik de 2de keuze ook maar half te lezezn
3) Voor deze 2 keuzes is geen beschrijving gegeven

Na het installeren (dat goed verliep) wou Firefox opstarten hierbij kreeg ik de volgende ofutmelding:
"title = "&updateWizard.title;"
---------^

na het afsluiten (door op het xje te klikken) van dit venster kreeg ik dit

"title="&mainwindow.title;"
--------^

<key id="key_inspectpage"
key="&inspectorTaskCmd.commandkey;"
-------^
modifier="accel.shift" command="Task:Inspectpage"/>

na het afsluiten (door op het xje te klikken) van dit venster gebeurde er niets meer, de output op mijn terminal was:

Code: Selecteer alles

** (firefox-installer-bin:21695): WARNING **: Invalid UTF8 string passed to pango_layout_set_text()

** (firefox-installer-bin:21695): WARNING **: Invalid UTF8 string passed to pango_layout_set_text()

** (firefox-installer-bin:21695): WARNING **: Invalid UTF8 string passed to pango_layout_set_text()

** (firefox-installer-bin:21695): WARNING **: Invalid UTF8 string passed to pango_layout_set_text()
nathan@debian:~/firefox-installer$
 reg - nsGMNotifierProgressListener
*** loading the extensions datasource

 reg - nsGMNotifierProgressListener
*** loading the extensions datasource
Mozilla/5.0 (X11; U; Linux i686; nl; rv:1.8) Gecko/20051111 Firefox/1.5
Gebruikersavatar
nirwana
Beheerder
Berichten: 11432
Lid geworden op: 19 september 2003, 5:09
    unknown unknown

Bericht door nirwana »

FFuser schreef:Na het installeren (dat goed verliep) wou Firefox opstarten hierbij kreeg ik de volgende ofutmelding:
"title = "&updateWizard.title;"
---------^

na het afsluiten (door op het xje te klikken) van dit venster kreeg ik dit

"title="&mainwindow.title;"
--------^

<key id="key_inspectpage"
key="&inspectorTaskCmd.commandkey;"
-------^
modifier="accel.shift" command="Task:Inspectpage"/>
Heb je een nieuw profiel aangemaakt voordat je deze nieuwe Firefox opstartte ? Dat wil nog wel eens dergelijke vage problemen verhelpen.
Al is het natuurlijk niet gegarandeerd dat er geen fouten in deze versies zitten. Het kan ook best zijn dat er in de Linux-versie van de vertaling nog een fout zit. Dat soort zaken kun je uitsluiten door met een nieuw profiel te beginnen.
Met vriendelijke groet,

Martijn
[ Mede-oprichter + webmaster MozBrowser | beheerder Startpagina's over freeware, GIMP, Mozilla en OpenOffice.org / LibreOffice, Ubuntu
Gebruikersavatar
FFuser
Berichten: 328
Lid geworden op: 11 augustus 2004, 19:25
Locatie: Antwerpen belgium
    unknown unknown

Bericht door FFuser »

nirwana schreef:
FFuser schreef:Na het installeren (dat goed verliep) wou Firefox opstarten hierbij kreeg ik de volgende ofutmelding:
"title = "&updateWizard.title;"
---------^

na het afsluiten (door op het xje te klikken) van dit venster kreeg ik dit

"title="&mainwindow.title;"
--------^

<key id="key_inspectpage"
key="&inspectorTaskCmd.commandkey;"
-------^
modifier="accel.shift" command="Task:Inspectpage"/>
Heb je een nieuw profiel aangemaakt voordat je deze nieuwe Firefox opstartte ? Dat wil nog wel eens dergelijke vage problemen verhelpen.
Al is het natuurlijk niet gegarandeerd dat er geen fouten in deze versies zitten. Het kan ook best zijn dat er in de Linux-versie van de vertaling nog een fout zit. Dat soort zaken kun je uitsluiten door met een nieuw profiel te beginnen.
Heb nu een nieuw profiel aangemaakt en de nieuwe firefox opgestart, het programma start wel op maar ik krijg vanonder een balk met de volgende foutmelding in

Code: Selecteer alles

<key id="Key_openHelp"
---------^
<key id="key_inspectpage" 
--^
key="&inspectorTaskCmd.commandkey;" 
Ik heb ook een vertaalopmerking
(Firefox is momenteel niet de standaardbrowser) tijdens het opstarten
"Ook tijdens de volgende keer opstarten conroleren" --> Altijd bij het opstarten controleren
Mozilla/5.0 (X11; U; Linux i686; nl; rv:1.8) Gecko/20051111 Firefox/1.5
Gebruikersavatar
nirwana
Beheerder
Berichten: 11432
Lid geworden op: 19 september 2003, 5:09
    unknown unknown

Bericht door nirwana »

FFuser schreef:Heb nu een nieuw profiel aangemaakt en de nieuwe firefox opgestart, het programma start wel op maar ik krijg vanonder een balk met de volgende foutmelding in

Code: Selecteer alles

<key id="Key_openHelp"
---------^
<key id="key_inspectpage" 
--^
key="&inspectorTaskCmd.commandkey;" 
Maar dat is wel 'goed', hoor. Althans, dat kreeg ik eerst ook in de Windows-versie (is inmiddels op magische wijze verdwenen na installatie van een extensie en daarna een herstart).
Nu heb je dus goed de nieuwe Firefox geinstalleerd en kun je het geheel verder gaan uitproberen.
Met vriendelijke groet,

Martijn
[ Mede-oprichter + webmaster MozBrowser | beheerder Startpagina's over freeware, GIMP, Mozilla en OpenOffice.org / LibreOffice, Ubuntu